pythonでget-pip実行時の参照先エラー

pythonでget-pip実行時の参照先エラー

Linux(FreeBSD)pythonでget-pip実行時の参照先エラー

手元の vagrant の環境(CentOS6.7)で python の pip コマンドが入っていなかったのでインストール。どうやら参照先が古いようで bootstrap.pypa.io を指定されました。

$ curl -kL https://raw.github.com/pypa/pip/master/contrib/get-pip.py > get-pip.py

$ python get-pip.py

You're using an outdated location for the get-pip.py script, please use the one available from https://bootstrap.pypa.io/get-pip.py

ダウンロード先を変更する

改めて bootstrap.pypa.io から get-pip.py を取得してインストールしますが、python2.6 のバージョンはドロップしちゃうよと警告が。そろそろ引退しないといけませんね。

$ curl -kL https://bootstrap.pypa.io/get-pip.py > get-pip.py

$ python get-pip.py

DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Collecting pip

(以下省略)

最終更新日:

関連記事

人気記事

新着情報